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Installation tiamo 2.x

1 Minimum system requirements

Operating system

RAM

Memory

Serial ports

USB ports

Screen

The windows user must have administrator rights in order to be able to install

the tiamo software.

32 bit version of;:

=  Windows 2000 SP4

= Windows XP Professional SP2

= Windows Vista Business / Enterprise / Ultimate
= Windows 7 Professional / Ultimate / Enterprise

Windows 2000 / Windows XP: 1 GB
Windows Vista, Windows 7: 2 GB
Program: 1 GB

Data: 2 GB

for devices with RS-232 interface
for devices with USB interface

Resolution 1024 x 768

Additional requirements for the tiamo server:

Operating system

Network
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32 bit version of:

=  Windows 2000 SP4

= Windows XP Professional SP2

=  Windows Vista Business / Enterprise / Ultimate
=  Windows 7 Professional / Ultimate / Enterprise
= Windows 2000 Server

= Windows Server 2003

= Windows Server 2008

= Windows Server 2008 R2

10 Mbit/s, stable and permanent

Communication via TCP/IP



Caution

During a determination data loss may occur when the PC switches over to the

standby mode. In the energy settings of the operating system the standby
mode should therefore be deactivated.

2 Single workplace installation

With the single workplace version tiamo light or tiamo full the workplace and
database will be installed on your computer.

1 Oninserting the CD into the drive of your computer the installation will be

started automatically. If this option is deactivated on your computer, double
click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

2 After having read the license agreement for tiamo and accepting it with
[Yes] a window will appear where you can enter the license code.

3 Enter the license code for tiamo light or tiamo full and click on [Next].

Metrohm Tiamo 2.0 Setup x|
License code
Flease type inyour license code. n Meﬂ‘ohm

License code |TI20

InstallShield

If you have entered the license code of an update license, then the license
code of the previous full version will additionally be requested.

< Back | Iext > I Cancel
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Metrohm Tiamo 2.0 Setup x|

License code

Please type in your license code. n MetrOhm

License code |TIZD -l alb2 -] c3d4 -l 4711 -] ab12 -] ff11

@ The licence code is valid only for & program update.
Flease enter the licence code of the previous full wersion.

License code | - - - - -

InstallShield

< Back | ext » I Cancel |

4 Now enter the target folder for the tiamo installation and confirm with

5

[Next].

In the dialog window Additional installation information you can
define the paths for the database and backup files:

Metrohm Tiamo 2.0 Setup il
Additional installation information.
Flease enter the necessary infarmation n Meh‘ohm

for the operation.

@ Every user needs readfwrite rights far the specified directaries!

Database path |C:\Programme\Metrohm\tiamo\Data

Default backup path |C:\Programme\Metrohm\tiamo\Backup

Advanced... |

InstallShield

The default paths differ in the different Windows versions.

< Back

Cancel |

Under [Advanced...] it is possible to change the ports tiamo uses to com-
municate with the database and administration server. If the ports are used
already, an appropriate error message will appear. Ask your system admin-
istrator for more information about this. Continue with [Next].



6 Follow the instructions of the program until the following message appears:

Metrohm Tiamo 2.0 Setup il

i If you use a firewal program please check its settings.
tiamo uses the following ports:
6001, 6002, 5645, 5646

This message points out which ports tiamo uses. Write down these ports
and inform your system administrator in case tiamo is not able to connect
to the database. Confirm the message with [OK].

7 Assoon as the copying procedure has been finished you can set further
workplace settings:

Metrohm Tiamo 2.0 Setup il
Workplace settings
Please setyour client 1D and your n Meh‘ohm

preferred language.

Client ID |PKL—NEI

[ This client I must existin the current tiamo
Sy/ETErm.

Language IEninsh LI

InstallShield

< Back | ext » I Cancel |

The option "The client ID must exist in the current tiamo system." is
only selectable if a database from a previous installation already exists on
your computer or if you want to connect to a database server which has
been installed on another computer.

If you activate this option tiamo checks whether the identifier you have
entered exists in the database. If this is true the identifier and all associated
settings will be adopted. With this option a renewed installation of a client
is much easier.

Click on [Next]. If the database ports are not available, an appropriate error
message will appear and the installation will be canceled. In this case, check
your server and firewall settings before installing the program again.

8 Atthe end of the installation the file info.txt will be created which contains
all relevant information concerning your current tiamo installation. Save
this file on your hard disk in case of need in future and print it (add to 1Q).
Complete the installation with [Finish].
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An InstallLog file with a list of all files having been copied to your computer
and with a confirmation for a successful installation is saved in the tiamo

installation folder (default: C:\Program Files\Metrohm\tiamo) under bin
\InstallLog.

3 Client/Server installation
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With the tiamo multi version (multiple workplace version with 3 licenses) you
can select during the installation whether you want to install a client (workplace)
or the server (incl. client) on your computer.

If you only want to install a client on your computer, in advance the server the
client will be connected to must have been installed on another computer.

1 Oninserting the CD into the drive of your computer the installation will be

started automatically. If this option is deactivated on your computer, double
click the file setup.exe.

If the minimum system requirements are not met (see above) a message
appears. Click on [Yes] if you like to install the program nevertheless.

Afterwards, click on [Next].

2 After having read the license agreement for tiamo and accepting it with
[Yes] a window will appear where you can enter the license code.

3 Enter the license code for tiamo multi and click on [Next].

Metrohm Tiamo 2.0 Setup x|
License code
Flease type inyour license code. n Meﬂ‘ohm

License code |TI20

InstallShield

If you have entered the license code of an update license, then the license
code of the previous full version will additionally be requested.

< Back | ext > I Cancel




Metrohm Tiamo 2.0 Setup x|

License code

Please type in your license code. n MetrOhm

License code |TIZD -l alb2 -] c3d4 -l 4711 -] ab12 -] ff11

@ Thelicence code is valid only for & program update.
Flease enter the licence code of the previous full wersion.

License code | - - - - -

InstallShield

< Back | ext » I Cancel |

4 Now enter the target folder for the tiamo installation and confirm with
[Next].

5 The dialog window Additional installation information appears where
you can select whether you want to install a client or the server:

Metrohm Tiamo 2.0 Setup il
Additional installation information.
Flease enter the necessary infarmation n Meh‘ohm

for the operation.

@ Client/Server

@ Every user needs readfwrite rights far the specified directaries!

Database path |C:\Programme\Metrohm\tiamo\Data |
Default backup path |C:\PrDgramme\Metrohm\tiamo\Backup |

 Client
SER/EL |
Advanced... |

InstallShield

< Back

The option workplace installs the client and the database server on your
computer. Select this option if your computer will be used as server.

With workplace only the client will be installed and with oo you have to
select the database server (has to be installed in advance!) to which you
want to connect. The network server name or the IP address are accepted.

Under [Advanced...] it is possible to change the ports tiamo uses to com-
municate with the database and administration server. If the ports are used
already, an appropriate error message will appear. Ask your system admin-
istrator for more information about this. Continue with [Next].
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6 All further installation steps correspond to those of the single workplace
installation on from point 6.

4 Modify / repair / remove installation and upgrade
license

In order to carry out modifications on the current tiamo installation, start the file
setup.exe on the installation CD or click on Metrohm tiamo under Control
Panel » Software. Then select Change/Remove.

Metrohm Tiamo 2.0 Setup x|
Welcome
todify. repair, update, or remove the program. n Meﬂ‘ohm

YWelcome to the Tiamo Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.

Select new program features to add or select currently installed features to
FEMTIOVE.

 Repair/Update
ﬁ Feinstall all program features installed by the previous setup.

(" License upgrade
= MNew license
Jia

 Bemove
@ Femove all installed features.

InstallShield

< Back | ext > I Cancel

Modify
With this option you can change the paths to the database and backup files and
set the ports which tiamo uses for communication. With the tiamo multi ver-
sion you can additionally change the path to the database server.

If the database path is changed, the existing databases are automatically copied
to the new location.

Repair/Update the program

With this option you can repair an existing defective installation or update an
older installation.

= Repair installation
In case of a defective tiamo installation because e.g. a DLL file is missing or
a program file has been deleted by mistake tiamo can be repaired with this
option.

= Update installation
In case an older version of tiamo is installed, it will be updated to the new
version of tiamo, see Program update with tiamo light/full or Program
update with tiamo multi.
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License upgrade

Remove

Caution

During updating older tiamo versions to tiamo 2.x the databases will be con-
verted to the new version. Depending on the size of the database, this can
take some time. For each database a progress bar is displayed which informs
about the status of the conversion.

The computer or Windows must not be restarted or shut down as long as the
conversion runs!

A direct upgrade of your current installation to a tiamo version with additional
features is possible:

= tiamo light to

tiamo full or tiamo multi
= tiamo full to

tiamo multi

In order to do this enter your new license code in the next dialog window.

This option removes your tiamo installation. Data which has been generated
after the installation (e.g. database entries, log files, exported data etc.) will
remain on your hard disk.

5 Program update with tiamo light/full

During the program update, the configuration database (system configuration,
methods, templates) and the determination databases are automatically updated
for further use with tiamo light/full.

The files in the database and backup directory will be retained when updating
the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories not having been overwritten
by the update will be deleted. The deleted files are listed in the InstallLog.

1 Save the configuration database into an external directory using the backup
function of tiamo. In the program part Configuration, select the menu
item File » Save » Manually. Select the Backup directory, enter a name
for the backup file and click on [Start]. The backup is carried out automat-
ically. It is recommended to copy the backup file to CD/DVD.

8.101.8032EN
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2

If desired, export the methods in addition to the automatic backup with the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. It is recommen-
ded to copy the exported methods to CD/DVD.

Save all determination databases created by yourself into an external direc-
tory using the backup function of tiamo. In the program part Database,
select the menu item File » Database manager.... Select the desired
database and click on [Backup.] Select the Backup directory, enter a
name for the backup file and click on [Start.] The backup is carried out
automatically. It is recommended to copy the backup file to CD/DVD.

Save further files created by yourself in the installation directory (e.g. export
files) into an external directory or to CD/DVD.

Close tiamo. Insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next].

Metrohm Tiamo 2.0 Setup x|
Welcome
todify. repair, update, or remove the program. n Meﬂ‘ohm

YWelcome to the Tiamo Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.

 todify
ﬁ Select new program features to add or select currently installed features to
FEMTIOVE.

=
Feinstall all program features installed by the previous setup.

(" License upgrade
= MNew license
Jia

 Bemove
@ Femove all installed features.

InstallShield

< Back | ext > I Cancel |

6 Enter the update license code for tiamo light or tiamo full and click on

[Next].
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Metrohm Tiamo 2.0 Setup x|

License code

Please type in your license code. n Metmhm

License code |TI20

InstallShield

< Back | ext > I Cancel

7 @ Caution

During updating older tiamo versions to tiamo 2.x the databases will be
converted to the new version. Depending on the size of the database,
this can take some time. For each database a progress bar is displayed
which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion runs!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to your com-
puter and with a confirmation for a successful installation is saved in the
tiamo installation folder (default: C:\Program Files\Metrohm\tiamo) under

bin\InstallLog.

6 Program update with tiamo multi

During the program update, the configuration database (system configuration,
methods, templates, user-specific data for all clients) and the determination
databases on the sever are automatically updated for further use with tiamo

multi.
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The files in the database and backup directory will be retained when updating
the program.

Files in the subdirectories bin, jre, lib, res, doc and examples will be over-
written by the update. The files in these directories not having been overwritten
by the update will be deleted. The deleted files are listed in the InstallLog.

1 Make sure tiamo multi is closed on all clients.

ﬂ Note

In the subdirectory bin of the tiamo installation there is the application
Clients.exe with which all clients and their status can be displayed.

2 Open tiamo multi on the server and save the configuration database into
an external directory using the backup function of tiamo. In the program
part Configuration, select the menu item File » Save » Manually. Select
the Backup directory, enter a name for the backup file and click on
[Start]. The backup is carried out automatically. It is recommended to copy
the backup file to CD/DVD.

3 If desired, export the methods in addition to the automatic backup with the
configuration database (see above) into an external directory. In the pro-
gram part Method, select the menu item File » Method manager....
Select the desired Method group, mark all methods to be exported and
click on [Edit] » Export.... Select the desired export directory and click on
[OK]. The methods are exported into the desired directory. It is recommen-
ded to copy the exported methods to CD/DVD.

4 Save all determination databases on the server into an external directory
using the backup function of tiamo. In the program part Database, select
the menu item File » Database manager.... Select the desired database
and click on [Backup]. Select the Backup directory, enter a name for the
backup file and click on [Start]. The backup is carried out automatically. It
is recommended to copy the backup file to CD/DVD.

5 Save further files in the installation directory (e.g. export files) into an exter-
nal directory or to CD/DVD.

6 Update server

Close tiamo multi on the server and on all clients. Insert the installation CD
on the server and double click the file setup.exe. Then select Repair/
Update and click on [Next].
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Metrohm Tiamo 2.0 Setup il

Welcome

todify. repair, update, or remove the program. n Meh‘ohm

YWelcome to the Tiamo Setup Maintenance program. This program lets you modify the current
installation. Click one of the options below.
" Modify

@ Select new program features to add or select currently installed features to
FEMTIOVE.

ﬁ Feinstall all program features installed by the previous setup.

(" License upgrade
= MNew license
Jia

 Bemove
@ Femove all installed features.

InstallShield

< Back | ext > I Cancel |

7 Enter the update license code for tiamo multi and click on [Next].

Metrohm Tiamo 2.0 Setup il
License code
Please type in your license code. n Meh‘ohm

License code |TI20 - - - - -

InstallShield

< Back | ext > I Cancel

The update of tiamo multi consists of the server license and three client

licenses. If an existing installation contains additional licenses, these will
be deleted.

Click on [OK] in the corresponding message in order to continue the instal-
lation.

8.101.8032EN



8.101.8032EN

9

10

11

Caution

During updating older tiamo versions to tiamo 2.x the databases will be
converted to the new version. Depending on the size of the database,
this can take some time. For each database a progress bar is displayed
which informs about the status of the conversion.

The computer or Windows must not be restarted or shut down as long
as the conversion runs!

Complete the installation with [Finish].

An UpdateLog file with a list of all files having been copied to the server
and with a confirmation for a successful installation is saved in the tiamo
installation folder (default: C:\Program Files\Metrohm\tiamo) under bin
\InstallLog.

In case additional licenses have been removed during the server update, of
if further additional licenses are to be added, the Administrator can enter
them in tiamo (dialog: Configuration » Tools » Program administra-
tion » Licenses > Add licenses).

Update clients

For each client, insert the installation CD and double click the file
setup.exe. Then select Repair/Update and click on [Next]. Complete the
installation with [Finish].

In order to facilitate updating many clients, the installation can be copied
from the CD to a writeable medium and the file tiamo_init.ini can be
modified. There, user-defined parameters (license code, installation path,
server name, ...) for the installation can be set in order one will only have
to click through the installation.

An UpdateLog file with a list of all files having been copied to the client
computer and with a confirmation for a successful installation is saved in
the tiamo installation folder (default: C:\Program Files\Metrohm\tiamo)
under bin\InstallLog.
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